Powerpoint presentations not working externally

I just had a problem with powerpoint presentations in Lync 2013 that behaved strangly.

All internal users could share and view powerpoints as they should, but all external users and guests could not. It behaved the same way in Lync 2013 clients as in the web app. It would just show “connecting” or “Waiting for the presentation to begin” before failing with a message that the network had gone down or the server was busy. There were no errors logged on the WAC server and no failures recorded on the monitoring database. I could also reach the https://wacserver.contoso.com/hosting/discovery through the TMG rule. Really weird.

After a bit of googling I found a forum post on technet where someone referenced a setting on the HTTP filter called “Verify Normalization”. The setting is found on the “Traffic” tab on the rule, like this:

Verify Normalization

Unticking this box solved the issue.

The rule is explained here, but it is basically a security mechanism that blocks URLs containing % sign if they are double encoded in the URL, although they can end up blocking legitimate traffic as well which is the case here. I do not know if this is a bug in WAC/OWAS or if it is by design though. Removing “Verify Normalization” from the rule will solve the issue in any case.

The URL the clients were accessing looked something like this, and contains a lot of url encoded characters.

https://lync-app.domain.no/m/Presenter.aspx?a=0&e=true&WopiSrc=https%3A%2F%2Flync-fe1.domain.no%2FDataCollabWeb%2Fwopi%2Ffiles%2F9-1-2C3E7AD&access_token=AAMFEOV5-KFUGNRfrclZBRMAVS8GEC3yB9HdElYrtUpQ8UkEs2KBEOV5-KFUGNRfrclZBRMAVS-CAr65gyAPlwe3U3NwCIa-PNE_Q7U3BPbx_s-yipQjZy9FKfOs04YIc2BBOb2J0AgIDURhdGFDb2xsYWJXZWI&<fs=FULLSCREEN&><rec=RECORDING&><thm=THEME_ID&><ui=UI_LLCC&><rs=DC_LLCC&&gt

OCS 2007 external access

When installing the OCS 2007 Enterprise pool/Standard edition front-end server, if you don’t configure external user access at once (i.e. OCS is installed and only planned to be an internal service), the external urls for Address book, Live Meeting content and Group Expansion are not configurable from the GUI.

They need to be configured from WMI or LCSCmd, ref

http://support.microsoft.com/kb/938288